summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-15 17:38:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-15 17:44:25 +0200
commit19f1aac0e7405b99c96823dda36e5389f18f64ec (patch)
tree94f16bc0a484e7b867a5f1e49c000f0a082d3cc8
parent86d3822862d655cfef7ee359464288d9953ec2c0 (diff)
gnu: Add r-lda.
* gnu/packages/cran.scm (r-lda): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 26b983067b..76ea2ed847 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14946,6 +14946,30 @@ library uses. It is also possible to control the number of threads in
OpenMP.")
(license license:agpl3+)))
+(define-public r-lda
+ (package
+ (name "r-lda")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lda" version))
+ (sha256
+ (base32
+ "03r4h5kgr8mfy44p66mfj5bp4k00g8zh4a1mhn46jw14pkhs21jn"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/lda/")
+ (synopsis "Collapsed Gibbs sampling methods for topic models")
+ (description
+ "This package implements @dfn{latent Dirichlet allocation} (LDA) and
+related models. This includes (but is not limited to) sLDA, corrLDA, and the
+mixed-membership stochastic blockmodel. Inference for all of these models is
+implemented via a fast collapsed Gibbs sampler written in C. Utility
+functions for reading/writing data typically used in topic models, as well as
+tools for examining posterior distributions are also included.")
+ ;; Any version of the LGPL
+ (license license:lgpl3+)))
+
(define-public r-rann-l1
(package
(name "r-rann-l1")