summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-15 17:02:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-15 17:03:23 +0200
commit6e7553ffe09ed214e1aac362c16b526743e3c25b (patch)
treee9fe9c07203b93fed76640b700a21b83189167cb
parent2cbe7044ea079b7852efb5c1a96785672c4e5c5b (diff)
gnu: Add r-rann-l1.
* gnu/packages/cran.scm (r-rann-l1): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 17c85fe512..adac3fe0c5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14945,3 +14945,26 @@ path of values for the regularization parameter.")
library uses. It is also possible to control the number of threads in
OpenMP.")
(license license:agpl3+)))
+
+(define-public r-rann-l1
+ (package
+ (name "r-rann-l1")
+ (version "2.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RANN.L1" version))
+ (sha256
+ (base32
+ "1hanh3my84mdr5wy6b89fawqzfc184vff1y65wy4l5ld9qza1n44"))))
+ (properties `((upstream-name . "RANN.L1")))
+ (build-system r-build-system)
+ (home-page "https://github.com/jefferis/RANN/tree/master-L1")
+ (synopsis "Fast nearest neighbour search using L1 metric")
+ (description
+ "This package provides tools to find the k nearest neighbours for every
+point in a given dataset in O(N log N) time using Arya and Mount's ANN
+library. There is support for approximate as well as exact searches, fixed
+radius searches and @code{bd} as well as @code{kd} trees. The distance is
+computed using the L1 (Manhattan, taxicab) metric.")
+ (license license:gpl3+)))