summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-15 17:02:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-15 17:03:23 +0200
commit9c3bfea673f13d84d12acc9189792564b98b930f (patch)
treec6b4ff9ac2fee9ef2b98ba5e5568e456412e67e3
parent6e7553ffe09ed214e1aac362c16b526743e3c25b (diff)
gnu: Add r-patchwork.
* gnu/packages/cran.scm (r-patchwork): New variable.
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index adac3fe0c5..ae6215b2d1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14968,3 +14968,34 @@ library. There is support for approximate as well as exact searches, fixed
radius searches and @code{bd} as well as @code{kd} trees. The distance is
computed using the L1 (Manhattan, taxicab) metric.")
(license license:gpl3+)))
+
+(define-public r-patchwork
+ ;; There has been no public release yet.
+ (let ((commit "fd7958bae3e7a1e30237c751952e412a0a1d1242")
+ (revision "1"))
+ (package
+ (name "r-patchwork")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thomasp85/patchwork.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00fq520xwy1ysg4k8x48x9b0yy9wyi8y8zj6dvxjg4bwx0yyp6s4"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)))
+ (home-page "https://github.com/thomasp85/patchwork")
+ (synopsis "Compose ggplot2 plots")
+ (description
+ "The @code{ggplot2} package provides a strong API for sequentially
+building up a plot, but does not concern itself with composition of multiple
+plots. Patchwork is a package that expands the API to allow for arbitrarily
+complex composition of plots by providing mathmatical operators for combining
+multiple plots.")
+ (license license:expat))))