summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmin Bandali <bandali@gnu.org>2019-08-06 02:42:11 -0400
committerRicardo Wurmus <rekado@elephly.net>2019-08-13 12:18:52 +0200
commitf9ccde24606fdb9ea10235e50e5898781eb913ff (patch)
tree0d71e6368e2fd98f103d91c3973d48bccbd608f5
parent39a6852acb17d812cd476cc4466f898cc1738287 (diff)
gnu: Add emacs-ebdb.
* gnu/packages/emacs-xyz.scm (emacs-ebdb): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index df184134c9..cbb4c90c94 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
+;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17215,3 +17216,28 @@ time.")
(description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
(license license:gpl3+)))
+
+;; The last release tarball is for version 0.6. We pick a commit close to
+;; version 0.6.10, which doesn't have a release tarball.
+(define-public emacs-ebdb
+ (let ((commit "2a87f5ed2a53e3a4e91e8c88ba5afc49f5e945df")
+ (revision "0"))
+ (package
+ (name "emacs-ebdb")
+ (version (git-version "0.6.10" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/girzel/ebdb.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fidy7z0c86dpqiss97sg5s92fd3fj4bdl8pqqdgg2m00jx4mrjz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/girzel/ebdb")
+ (synopsis "EIEIO port of BBDB, Emacs's contact-management package")
+ (description "EBDB is a contact management/addressbook package for
+Emacs. It's a re-write of the Insidious Big Brother Database (BBDB) using
+Emacs Lisp's (relatively new) EIEIO object oriented libraries.")
+ (license license:gpl3+))))