summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:00 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-15 01:24:28 -0500
commit02824cda55609eb4c0d991f6ebe6634ab9517178 (patch)
tree3a75b0ebafa41f639f33a75c84f49d306532c564
parent2a58ddb6da700978109f97a05157b6f9c758038c (diff)
gnu: Add go-github-com-riywo-loginshell.
* gnu/packages/golang.scm (go-github-com-riywo-loginshell): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aa3f7f0b70..61ceceea0d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10484,6 +10484,32 @@ email library.")
"The pty package provides functions for working with Unix pseudoterminals.")
(license license:expat)))
+(define-public go-github-com-riywo-loginshell
+ (package
+ (name "go-github-com-riywo-loginshell")
+ (version "0.0.0-20200815045211-7d26008be1ab")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/riywo/loginshell")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "138yvis6lipw9x02jyiz7472bxi20206bcfikcar54i3xsww9q4i"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/riywo/loginshell"
+ ;; Tests try to get the current user's login shell; the build
+ ;; user doesn't have one.
+ #:tests? #f))
+ (home-page "https://github.com/riywo/loginshell")
+ (synopsis "Get the user's login shell in Go")
+ (description
+ "The loginshell package provides a Go library to get the login shell
+of the current user.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar