summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-27 23:14:54 +0100
committerChristopher Baines <mail@cbaines.net>2023-11-05 18:09:36 +0000
commit0420667cbe89d94f5d26ba078bb5a764e1295291 (patch)
treedf8f990486eb94d89d629b30e45fbe83c2c800e5
parent20e7aa2732368a7c6922eae7baa6e28ce032b384 (diff)
gnu: python-astropy: Update to 5.3.4.
* gnu/packages/astronomy.scm (python-astropy): Update to 5.3.4. [arguments]{phases}: Disable one failing test, reported upstream. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 86c63aecde..d5c6c4c8a9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1466,13 +1466,13 @@ accurately in real time at any rate desired.")
(define-public python-astropy
(package
(name "python-astropy")
- (version "5.3.3")
+ (version "5.3.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astropy" version))
(sha256
- (base32 "1fwk7x4q1hgdf9m8q613c6q7045sam1g934vgqv588ksbngxyc03"))
+ (base32 "1n7iwvjari4xv37094cpiapmjhhm57b04hi4r40wqb5czbigg46l"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1527,7 +1527,9 @@ accurately in real time at any rate desired.")
"not remote_data"
;; XXX: Check why this tests failing.
" and not test_ignore_sigint"
- " and not test_parquet_filter"))))))))
+ " and not test_parquet_filter"
+ ;; See https://github.com/astropy/astropy/issues/15537
+ " and not test_pvstar"))))))))
(native-inputs
(list pkg-config
python-colorlog