summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-25 13:42:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-25 13:44:41 +0100
commit04724e59971b03f86a410285653d24005c62b924 (patch)
treeb780817f51d060e978b3898ff1481814c499e3aa
parenta7f118d062db4408b23505750c44a1f996496c43 (diff)
gnu: Add r-ctrialsgov.
* gnu/packages/cran.scm (r-ctrialsgov): New variable.
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a36c845479..872e36483d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5498,6 +5498,42 @@ freedom to design figures for better understanding complex patterns behind
multi-dimensional data.")
(license license:gpl2+)))
+(define-public r-ctrialsgov
+ (package
+ (name "r-ctrialsgov")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ctrialsgov" version))
+ (sha256
+ (base32
+ "0hdh1fdfaja8amf7fkvk1c6yif703132bvacq0j9pk5jr97czgpw"))))
+ (properties `((upstream-name . "ctrialsgov")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dbi
+ r-dplyr
+ r-ggplot2
+ r-htmlwidgets
+ r-lubridate
+ r-matrix
+ r-plotly
+ r-purrr
+ r-rlang
+ r-stringi
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=ctrialsgov")
+ (synopsis
+ "Query data from U.S. National Library of Medicine's Clinical Trials Database")
+ (description
+ "This package provides tools to query the U.S. National Library of
+Medicine's Clinical Trials database. Functions are provided for a variety of
+techniques for searching the data using range queries, categorical filtering,
+and by searching for full-text keywords. Minimal graphical tools are also
+provided for interactively exploring the constructed data.")
+ (license license:expat)))
+
(define-public r-powerlaw
(package
(name "r-powerlaw")