summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZzull <bstrazzull@hotmail.fr>2022-09-24 17:27:25 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-04 18:15:35 +0200
commit0669bf64f788a6fe8567f4ae16c022583df1a5f8 (patch)
tree252d1db168c3a8b24cb786ba33cdf5b36d6ccea1
parentf83622f17d21d684e431fe14731349b952411368 (diff)
gnu: Add python-property-manager.
* gnu/packages/python-xyz.scm (python-property-manager): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 754eff6c44..9f0275cb68 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -130,6 +130,7 @@
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
+;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7297,6 +7298,30 @@ buffer transformation, compression, and decompression functions for use in the
tifffile, czifile, and other scientific image input/output modules.")
(license license:bsd-3)))
+(define-public python-property-manager
+ (package
+ (name "python-property-manager")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "property-manager" version))
+ (sha256
+ (base32 "0m3w4spr8f39xnm65naw29ncal4r453kn7ndqb63rwbsmslnvrwk"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest-cov))
+ (propagated-inputs
+ (list python-verboselogs
+ python-humanfriendly
+ python-coloredlogs))
+ (home-page "https://github.com/xolox/python-property-manager")
+ (synopsis "Useful property variants for Python programming")
+ (description "The @code{property-manager} package defines several custom
+property variants for Python programming including required properties,
+writable properties, cached properties, etc.")
+ (license license:expat))) ; MIT license
+
(define-public python-executing
(package
(name "python-executing")