summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-24 19:49:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-24 19:49:02 +0300
commit0d046c3a456121dc7353dd8023667e1f70ecd264 (patch)
tree4d612912e8783485931eeb8622bd752289f7bcf4
parent3fdd6d6228c2e002c693ece937b85affb78f43d8 (diff)
gnu: tslib: Update to 1.23.
* gnu/packages/video.scm (tslib): Update to 1.23. [source]: Download using release tarball. [native-inputs]: Remove autoconf, automake, libtool. Change-Id: Ib3d33cb33eba39f8c273b8737b39b54f6c8f7819
-rw-r--r--gnu/packages/video.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e5ec161ba4..b5211aaa62 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -729,26 +729,20 @@ other software.")
(define-public tslib
(package
(name "tslib")
- (version "1.22")
+ (version "1.23")
(source
(origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/libts/tslib")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://github.com/libts/tslib/releases/download/"
+ version "/tslib-" version ".tar.xz"))
(sha256
- (base32 "197p6vy539wvfrv23agbvmay4rjya1jnisi46llm0nx4cvqh48by"))))
+ (base32 "1b0xk746dcf72rd8xkxnjfn3axc57y6ahmg95wgj01l0sia9lj4v"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "tests"
- #:configure-flags
- (list "--with-sdl2")))
- (native-inputs
- (list autoconf automake libtool pkg-config))
- (inputs
- `(("sdl2" ,sdl2)))
+ #:configure-flags (list "--with-sdl2")))
+ (native-inputs (list pkg-config))
+ (inputs (list sdl2))
(synopsis "Touchscreen access library")
(description "TSLib is a cross-platform library that provides access to
touchscreen devices and the ability to apply filters to their input events.")