summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:06:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:44 +0200
commit0eaab89b0f013d06f1ca158618dfa554c4d8f71e (patch)
tree81d7fc62a085c45b3e79ced38ec25c021bbfe55a
parentb74161bc547c944dddf84c8d282051d3f485d6c0 (diff)
gnu: Add texlive-swrule.
* gnu/packages/tex.scm (texlive-swrule): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 17f63c6aae..234a8da643 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3676,6 +3676,28 @@ the resolution used in the Metafont printer parameters.")
"The package provides a simple key/value system for TeX and LaTeX.")
(license license:lppl1.3c)))
+(define-public texlive-swrule
+ (package
+ (name "texlive-swrule")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/generic/swrule/")
+ (base32
+ "075mshpyi9gxbi3n0hbh3ygidzw1daxy697lhc7cc99i39y8scpi")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/swrule")
+ (synopsis "Lines thicker in the middle than at the ends")
+ (description
+ "This package defines commands that create rules split into
+a (specified) number of pieces, whose size varies to produce the
+effect of a rule that swells in its centre.")
+ ;; Library mentions: "The style package is copyrighted but may be used and
+ ;; extended in any way, as long as a pointer to the original author is
+ ;; maintained. The author is not liable for any problem that may or may
+ ;; not result from using this package. Use at your own risk".
+ (license (license:fsf-free "file://tex/generic/swrule/swrule.sty"))))
+
(define-public texlive-tex
(package
(name "texlive-tex")