summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:59:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:46 +0200
commit0ee60c18c197b1679b566004af0aa681e64192a5 (patch)
treec4dfac231a03c57461e5bea4b7865ae1ee08a40c
parenta6325c7ae9289606774989ca9c264f5ba1872c79 (diff)
gnu: Add texlive-stix2-type1.
* gnu/packages/tex.scm (texlive-stix2-type1): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c0d15b5ba7..0d0d5ef587 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23988,6 +23988,36 @@ a complete set of mathematical glyphs. This package is considered obsolete.
See @code{stix2-otf} and @code{stix2-type1} instead.")
(license (list license:silofl1.1 license:lppl1.3+))))
+(define-public texlive-stix2-type1
+ (package
+ (name "texlive-stix2-type1")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/stix2-type1/"
+ "fonts/enc/dvips/stix2-type1/"
+ "fonts/map/dvips/stix2-type1/"
+ "fonts/tfm/public/stix2-type1/"
+ "fonts/type1/public/stix2-type1/"
+ "source/fonts/stix2-type1/"
+ "tex/latex/stix2-type1/")
+ (base32
+ "0jsnyxbi5054fw0j5jw9cisj9xm8i8gf1f48m9l77bkybq0qviwp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/stix2-type1")
+ (synopsis "Type1 versions of the STIX Two OpenType fonts")
+ (description
+ "The @code{stix2} package provides minimal support for using the STIX Two
+fonts with versions of TeX that are limited to TFM files, Type 1 PostScript
+fonts, and 8-bit font encodings.
+
+Some glyphs that are traditionally available in TeX math fonts are not yet
+available in the STIX Two OpenType fonts. In such cases, we have chosen to
+omit them from the @code{stix2} package rather than create incompatibilities
+between the OpenType and Type 1 versions.")
+ (license (list license:silofl1.1 license:lppl1.3+))))
+
(define-public texlive-structmech
(package
(name "texlive-structmech")