summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 14:03:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 14:03:21 +0100
commit0ef062b338962dbe9b3c28334643b2410fbfef78 (patch)
tree2a9871a0d0a17796caee57052256ed51f5d25847
parent469fb438918df593f6c38b18e78532a25be2ccef (diff)
gnu: r-bookdown: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-bookdown): Move from here... * gnu/packages/cran.scm (r-bookdown): ...to here.
-rw-r--r--gnu/packages/bioinformatics.scm24
-rw-r--r--gnu/packages/cran.scm24
2 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7d3b34d1a9..dcee9438a9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7266,30 +7266,6 @@ categorize packages in a Bioconductor package repository according to keywords,
also known as views, in a controlled vocabulary.")
(license license:artistic2.0)))
-(define-public r-bookdown
- (package
- (name "r-bookdown")
- (version "0.9")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "bookdown" version))
- (sha256
- (base32
- "0vg1s1w0l9pm95asqb21yf39mfk1nc9rdhmlys9xwr7p7i7rsz32"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-htmltools" ,r-htmltools)
- ("r-knitr" ,r-knitr)
- ("r-rmarkdown" ,r-rmarkdown)
- ("r-tinytex" ,r-tinytex)
- ("r-yaml" ,r-yaml)
- ("r-xfun" ,r-xfun)))
- (home-page "https://github.com/rstudio/bookdown")
- (synopsis "Authoring books and technical documents with R markdown")
- (description "This package provides output formats and utilities for
-authoring books and technical documents with R Markdown.")
- (license license:gpl3)))
-
(define-public r-biocstyle
(package
(name "r-biocstyle")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d4564f4f49..03aa2f59f5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12669,3 +12669,27 @@ SELECT or UPDATE queries to an end-point.")
;; The only license indication is found in the DESCRIPTION file,
;; which states GPL-3. So we cannot assume GPLv3+.
(license license:gpl3)))
+
+(define-public r-bookdown
+ (package
+ (name "r-bookdown")
+ (version "0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "bookdown" version))
+ (sha256
+ (base32
+ "0vg1s1w0l9pm95asqb21yf39mfk1nc9rdhmlys9xwr7p7i7rsz32"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-tinytex" ,r-tinytex)
+ ("r-yaml" ,r-yaml)
+ ("r-xfun" ,r-xfun)))
+ (home-page "https://github.com/rstudio/bookdown")
+ (synopsis "Authoring books and technical documents with R markdown")
+ (description "This package provides output formats and utilities for
+authoring books and technical documents with R Markdown.")
+ (license license:gpl3)))