summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-25 21:41:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-25 22:19:37 +0200
commit0f8b84b3904300ad14d440859fd9b01d23889cc4 (patch)
treec6424b7c1f0c677d9536250bd75688eb0ae94afa
parent1c87d1507a4a92818b9868e56d4195a63932ae1e (diff)
gnu: emacs-inspector: Update to 0.31.
* gnu/packages/emacs-xyz.scm (emacs-inspector): Update to 0.31. [arguments]: Do not load "tree-inspector-tests.el", which was moved to another repository. [propagated-inputs]: Remove EMACS-TREEVIEW.
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 469028b69b..e57992daca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -738,10 +738,10 @@ configuration language which makes it trivial to write your own themes.")
(license license:gpl3+)))
(define-public emacs-inspector
- (let ((commit "f06e3490cb3fba9335dfca9022d3cc8babaa8654")) ;version bump
+ (let ((commit "baa486ac2e4faed9a362322c0b2914d6f0c59ede")) ;version bump
(package
(name "emacs-inspector")
- (version "0.30")
+ (version "0.31")
(source
(origin
(uri (git-reference
@@ -749,18 +749,16 @@ configuration language which makes it trivial to write your own themes.")
(commit commit)))
(method git-fetch)
(sha256
- (base32 "08pxcjbarl9d0hrapspw38axg64m8a518wgxh19nbpik7sm3fzxd"))
+ (base32 "0xdgbs8kmsq1m9h9ykjkdvfn0xqf9gmhckr00lq8dxm0gab7x961"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(arguments
(list
#:tests? #t
#:test-command #~(list "emacs" "-Q" "--batch"
- "-L" "."
+ "-l" "inspector.el"
"-l" "inspector-tests.el"
- "-l" "tree-inspector-tests.el"
"-f" "ert-run-tests-batch-and-exit")))
- (propagated-inputs (list emacs-treeview))
(home-page "https://github.com/mmontone/emacs-inspector")
(synopsis "Inspection tool for Emacs Lisp objects")
(description