summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-14 11:07:31 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-19 23:51:11 +0100
commit10541dca6a621a994f6d7d74d4d9ca9a71867213 (patch)
treea94170199c4a86ed1635533d10df53be8f7fbfaf
parent8d88ef1ac72a36010f23e4e3a158c44f4eb50132 (diff)
gnu: glibc-utf8-locales: Add the C.UTF-8 locale.
* gnu/packages/base.scm (%default-utf8-locales): Add "C". (make-glibc-utf8-locales): Delete "C" from LOCALES for glibc versions lower than or equal to 2.35. Change-Id: I6a6faa68dc18bf0f87c372109a17f476d3561278
-rw-r--r--gnu/packages/base.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d31c0b0772..eab9ff411d 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1396,7 +1396,8 @@ to the @code{share/locale} sub-directory of this package.")
(define %default-utf8-locales
;; These are the locales commonly used for tests---e.g., in Guile's i18n
;; tests.
- '("de_DE" "el_GR" "en_US" "fr_FR" "tr_TR"))
+ '("C" "de_DE" "el_GR" "en_US" "fr_FR" "tr_TR"))
+
(define*-public (make-glibc-utf8-locales glibc #:key
(locales %default-utf8-locales)
(name "glibc-utf8-locales"))
@@ -1444,7 +1445,14 @@ to the @code{share/locale} sub-directory of this package.")
(symlink (string-append locale ".utf8")
(string-append localedir "/"
locale ".UTF-8")))
- '#$locales)))))
+
+ ;; The C.UTF-8 locale was introduced in 2.35 but it
+ ;; fails to build there:
+ ;; <https://sourceware.org/bugzilla/show_bug.cgi?id=28861>.
+ '#$(if (version>? (package-version this-package)
+ "2.35")
+ locales
+ (delete "C" locales)))))))
(native-inputs (list glibc gzip))
(synopsis (if default-locales?
(P_ "Small sample of UTF-8 locales")