summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-27 16:18:31 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-27 16:34:35 +0200
commit15e716740564485f2e14cadca1cd50c2aa450fe7 (patch)
tree270b9a874cc1c099687ce3aab5fa5f6e474d50e4
parent6c443975c9cb94131f5956378495c6e3b627b6aa (diff)
gnu: inetutils: Do not refer to canonical coreutils.
Make sure not to retain a reference to the canonical coreutils package. The Guix System closure size would otherwise be increased by including references to both canonical and non-canonical version of those packages. * gnu/packages/admin.scm (inetutils)[inputs]: Add "coreutils", [arguments]: and point to it with PATHDEF_CP variable.
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 61a98cc1cc..1641bdf99d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -623,10 +623,16 @@ re-executing them as necessary.")
"--disable-uucpd"
"--disable-whois")
'()))
+ ;; Make sure that canonical "coreutils" package is not referred.
+ #:make-flags
+ (list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
+ (assoc-ref %build-inputs "coreutils*")
+ "/bin/cp\\\""))
;; On some systems, 'libls.sh' may fail with an error such as:
;; "Failed to tell switch -a apart from -A".
#:parallel-tests? #f))
- (inputs `(("ncurses" ,ncurses)
+ (inputs `(("coreutils*" ,coreutils)
+ ("ncurses" ,ncurses)
("readline" ,readline))) ;for 'ftp'
(native-inputs (if (member (%current-system)
(package-supported-systems net-tools))