summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-09 23:01:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:07 +0200
commit1aa1a6a8161e59d909381b9bad838df74e072138 (patch)
tree0bff81c77fb9f8eb84b380ddf5c842c0f1136b5e
parentd32334eea20723e37a7e506273f71da9fa84b5e0 (diff)
gnu: Add python-types-setuptools.
* gnu/packages/python-xyz.scm (python-types-setuptools): New variable.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cc44463abb..a2a84830da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30975,6 +30975,22 @@ static types.")
Python, with static types.")
(license license:asl2.0)))
+(define-public python-types-setuptools
+ (package
+ (name "python-types-setuptools")
+ (version "67.6.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-setuptools" version))
+ (sha256
+ (base32
+ "0qlrxgl4mz6hs8z4qnl91hsa8mqcfm6397s3s3j21imxqxk8ww1s"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for setuptools")
+ (description "This package provides typing stubs for setuptools.")
+ (license license:asl2.0)))
+
(define-public python-psycopg2-binary
(package
(name "python-psycopg2-binary")