summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:54:58 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:08:01 -0400
commit1be788344b2713866aa89c21d4d924a342d1511c (patch)
tree6fce912e8c47cc7814cacb8405131f5923bbaf40
parentdf9d178b21af57dfae088e5d25735298ae5f5047 (diff)
gnu: Add texlive-cmbright.
* gnu/packages/tex.scm (texlive-cmbright): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2779916bf4..dfc82c99b0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16832,6 +16832,33 @@ mathematical fonts in a range of styles, based on Monotype Modern 8A.")
(define-deprecated-package texlive-fonts-cm texlive-cm)
+(define-public texlive-cmbright
+ (package
+ (name "texlive-cmbright")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/cmbright/"
+ "doc/latex/cmbright/"
+ "fonts/source/public/cmbright/"
+ "fonts/tfm/public/cmbright/"
+ "source/latex/cmbright/"
+ "tex/latex/cmbright/")
+ (base32
+ "0sj6g877p6ak045x7737g3lg4kab8hgc2s2g6i23dw9d35csqf8d")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-amsfonts texlive-ec texlive-metafont))
+ (home-page "https://ctan.org/pkg/cmbright")
+ (synopsis "Computer Modern Bright fonts")
+ (description
+ "This package provides a family of sans serif fonts for TeX and LaTeX,
+based on Donald Knuth's CM fonts. It comprises OT1, T1 and TS1 encoded text
+fonts of various shapes as well as all the fonts necessary for mathematical
+typesetting, including AMS symbols. This collection provides all the
+necessary files for using the fonts with LaTeX.")
+ (license license:lppl)))
+
(define-public texlive-cmcyr
(package
(name "texlive-cmcyr")