summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-10-04 20:36:24 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-10-04 20:36:24 +0200
commit1c821a3a6347c8e0476225adaf077f69e19dc449 (patch)
treed4858bc47f28b0881fa5297e8291b7228e03482e
parentecee392ef1b9335afb2268c889d891a9ba1a4681 (diff)
gnu: icedove: Update to 102.3.1 [security fixes].
Fixes CVE-2022-39236, CVE-2022-39249, CVE-2022-39250 and CVE-2022-39251. * gnu/packages/gnuzilla.scm (icedove): Update to 102.3.1.
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index bb285eab70..304b98832e 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1240,11 +1240,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20220920000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20220928000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "102.3.0")
+ (version "102.3.1")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1531,7 +1531,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "04f60827c1b53ab86121c7d122d3a8216219ff9f"))
+ ,(let ((changeset "07a17b101f904a686bbdf798ba2e820079a8323f"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1540,7 +1540,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "078jrxpzqj45l84i39a9fq023j71ngca5gs2ngpjsbily51bzx09")))))
+ "16wlpcv1n64crcgk4gcl92r37dlpw26izvam82pbp5f8c25amlnk")))))
("cargo" ,(force rust-1.59-promise) "cargo")
("clang" ,clang)
("llvm" ,llvm)