summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos via Guix-patches via <guix-patches@gnu.org>2023-08-21 10:25:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-03 12:31:17 +0200
commit1de41d5a1f789626c6fe9987cd77888c76607d54 (patch)
tree5a6e39adbe329a55f83c4644c5235ead5dd6f299
parent9d2e6323775371ab0ccaec0fc1df3b50335c41ea (diff)
gnu: emacs-org-ref: Update to 3.0-0.bb375f3.
* gnu/packages/emacs-xyz.scm (emacs-org-ref): Update to 3.0-0.bb375f3. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm71
1 files changed, 42 insertions, 29 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5ff9dc6879..4b480ce7ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24194,34 +24194,47 @@ their meaning for the current Emacs major-mode.")
(license license:gpl3+)))
(define-public emacs-org-ref
- (package
- (name "emacs-org-ref")
- (version "2.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jkitchin/org-ref")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0xd1qp8dfy8n8b2n3rsdzm8vrfl7dii142kw330s8jp3pavww1f6"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-dash
- emacs-f
- emacs-helm
- emacs-helm-bibtex
- emacs-htmlize
- emacs-hydra
- emacs-ivy
- emacs-key-chord
- emacs-pdf-tools
- emacs-s))
- (home-page "https://github.com/jkitchin/org-ref")
- (synopsis "Citations, cross-references and bibliographies in Org mode")
- (description
- "Org Ref is an Emacs library that provides rich support for citations,
+ (let ((commit "bb375f366f883e5b60e3bb625f2acd026811fb55")
+ (revision "0"))
+ (package
+ (name "emacs-org-ref")
+ (version (git-version "3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jkitchin/org-ref")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01wxcyzdrx6ysv9rjd64fr7kkvm4fjr03ib4mmpchraxxm8g8z43"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:include #~(cons* "org-ref.org" "org-ref.bib" %default-include)
+ #:exclude #~(list
+ ;; github.com/jkitchin/org-ref/issues/1085
+ "openalex.el"
+ ;; author doesn't recommend using it
+ "org-ref-pdf.el")))
+ (propagated-inputs
+ (list emacs-avy
+ emacs-citeproc-el
+ emacs-dash
+ emacs-f
+ emacs-helm
+ emacs-helm-bibtex
+ emacs-htmlize
+ emacs-hydra
+ emacs-ivy
+ emacs-ox-pandoc
+ emacs-parsebib
+ emacs-s))
+ (home-page "https://github.com/jkitchin/org-ref")
+ (synopsis "Citations, cross-references and bibliographies in Org mode")
+ (description
+ "Org Ref is an Emacs library that provides rich support for citations,
labels and cross-references in Org mode.
The basic idea of Org Ref is that it defines a convenient interface to insert
@@ -24239,7 +24252,7 @@ a DOI.
Org Ref is especially suitable for Org documents destined for LaTeX export and
scientific publication. Org Ref is also useful for research documents and
notes.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-org-reveal
(let ((commit "f55c851bf6aeb1bb2a7f6cf0f2b7bd0e79c4a5a0"))