summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Wilson <elaexuotee@wilsonb.com>2023-09-14 14:55:13 +0900
committerLudovic Courtès <ludo@gnu.org>2023-10-18 23:01:07 +0200
commit1e11506f730b08413c79555492d71563bef77a4f (patch)
treeb1af122dd1e82efe55cfbfe024df3f986267c3f0
parent8f485817084ac6d93db085da5271e94bc5b237f7 (diff)
gnu: Add ipvsadm.
* gnu/packages/linux.scm (ipvsadm): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6cd9540da3..457e41f303 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10509,6 +10509,46 @@ against the several transient execution CVEs that were published since early
random programs using differential testing.")
(license license:bsd-4)))
+(define-public ipvsadm
+ (package
+ (name "ipvsadm")
+ (version "1.31")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kernel.org/pub/linux/utils/kernel"
+ "/ipvsadm/ipvsadm-" version ".tar.xz"))
+ (sha256
+ (base32 "1nyzpv1hx75k9lh0vfxfhc0p2fpqaqb38xpvs8sn88m1nljmw2hs"))))
+ (build-system gnu-build-system)
+ (native-inputs (list linux-libre-headers pkg-config which))
+ (inputs (list libnl popt))
+ (arguments
+ (list #:tests? #f
+ #:parallel-build? #f ;build fails randomly with '-j'
+ #:make-flags
+ #~(list (string-join
+ (list "CFLAGS="
+ (string-append "-I"
+ #$(this-package-input "libnl")
+ "/include/libnl3")
+ (string-append "-L" #$(this-package-input "libnl")
+ "/lib")
+ "-fPIC")
+ " ")
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "SBIN=" #$output "/sbin")
+ (string-append "INIT=" #$output "/etc/init.d")
+ (string-append "MANDIR=" #$output "/share/man"))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://www.linuxvirtualserver.org/software/ipvs.html")
+ (synopsis "IP virtual server administration utility")
+ (description "@code{ipvsadm(8)} is used to set up, maintain or inspect the
+virtual server table in the Linux kernel. The Linux Virtual Server can be used
+to build scalable network services based on a cluster of two or more nodes.")
+ (license license:gpl2+)))
+
(define-public ryzen-smu
(package
(name "ryzen-smu")