summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:05:52 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:10:54 -0400
commit1e82e148e1d15f2faa761ec9f50f9392039696d2 (patch)
tree76c1a03724eb8964dc56a1a809b02d0c3d6c3b40
parent7d08b594952aa1b2a18bbb79888a6717e4691866 (diff)
gnu: libxslt: Set search-paths for XML and SGML catalogs.
According to xsltproc manpage it supports both XML_CATALOG_FILES and SGML_CATALOG_FILES for catalog lookup. Since the native-search-paths field is not thunked, doing (package-native-search-paths libxslt) can lead to module import cycles so we define a %libxslt-search-paths variable to avoid this kind of trouble. * guix/search-paths.scm (%libxslt-search-paths): New variable. * gnu/packages/xml.scm (libxslt)[native-search-paths]: Set to %libxslt-search-paths. * gnu/packages/perl.scm (perl-app-xml-docbook-builder)[native-search-paths]: Ditto. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/perl.scm4
-rw-r--r--gnu/packages/xml.scm1
-rw-r--r--guix/search-paths.scm4
3 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 267a35e560..f0b91e6b65 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -599,9 +599,7 @@ requires only 10MB of RAM.")
(list libxslt))
(propagated-inputs
(list perl-class-xsaccessor perl-test-trap))
- (native-search-paths
- ;; xsltproc's search paths, to avoid propagating libxslt.
- (list $XML_CATALOG_FILES))
+ (native-search-paths %libxslt-search-paths)
(home-page "https://www.shlomifish.org/open-source/projects/docmake/")
(synopsis "Translate DocBook/XML documentation into other file formats")
(description
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 16aabffca8..0b31bb5928 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -365,6 +365,7 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
xz))
(native-inputs
(list pkg-config))
+ (native-search-paths %libxslt-search-paths)
(description
"Libxslt is an XSLT C library developed for the GNOME project. It is
based on libxml for XML parsing, tree manipulation and XPath support.")
diff --git a/guix/search-paths.scm b/guix/search-paths.scm
index d325e57989..a935684952 100644
--- a/guix/search-paths.scm
+++ b/guix/search-paths.scm
@@ -46,6 +46,7 @@
$XML_CATALOG_FILES
%gcc-search-paths
+ %libxslt-search-paths
search-path-specification->sexp
sexp->search-path-specification
@@ -179,6 +180,9 @@
(file-pattern "^catalog\\.xml$")
(file-type 'regular)))
+(define %libxslt-search-paths
+ (list $SGML_CATALOG_FILES $XML_CATALOG_FILES))
+
(define (search-path-specification->sexp spec)
"Return an sexp representing SPEC, a <search-path-specification>. The sexp
corresponds to the arguments expected by `set-path-environment-variable'."