summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-19 10:15:52 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-19 10:25:16 +0100
commit1eaa9553d33b144e0c006ab3194d5278304f7e34 (patch)
tree9199b3640f14edee4e50f91c4e3e22ac1419d00b
parent801b5c7c2fc5cc268a2818e1eec12abfa9a94f4d (diff)
gnu: emacs-logos: Update to 1.0.1.
* gnu/packages/emacs-xyz.scm (emacs-logos): Update to 1.0.1.
-rw-r--r--gnu/packages/emacs-xyz.scm65
1 files changed, 34 insertions, 31 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c1de30358c..8e11c579cb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14515,40 +14515,43 @@ such files while providing facilities to link between them.")
(license license:gpl3+)))
(define-public emacs-logos
- (package
- (name "emacs-logos")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~protesilaos/logos")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1s1bm8hipipxkcz558h7i21z19g5jsbpqaza8nr4mx03jdp4nsxf"))))
- (native-inputs (list texinfo))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'makeinfo
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "emacs"
- "--batch"
- "--eval=(require 'ox-texinfo)"
- "--eval=(find-file \"README.org\")"
- "--eval=(org-texinfo-export-to-info)")
- (install-file "logos.info" (string-append #$output "/share/info")))))))
- (home-page "https://protesilaos.com/emacs/logos")
- (synopsis "Simple focus mode for Emacs")
- (description "This package provides a simple focus mode which can be
+ ;; XXX: Upstream did not tag latest release. Use the commit matching
+ ;; version bump.
+ (let ((commit "d8f18f74591ffcac6466409ac7cd29f90838b2fe"))
+ (package
+ (name "emacs-logos")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/logos")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g3jxzwv99wkxlb36j2nyjibayvwjpy7qc2mz9lfd2945q6apj3z"))))
+ (native-inputs (list texinfo))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(find-file \"README.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (install-file "logos.info" (string-append #$output "/share/info")))))))
+ (home-page "https://protesilaos.com/emacs/logos")
+ (synopsis "Simple focus mode for Emacs")
+ (description "This package provides a simple focus mode which can be
applied to any buffer for reading, writing, or even doing a presentation. The
buffer can be divided in pages using the @code{page-delimiter}, outline
structure, or any other pattern.")
- (license (list license:gpl3+
- license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+ (license (list license:gpl3+
+ license:fdl1.3+))))) ; GFDLv1.3+ for the manual
(define-public emacs-tmr
(package