summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-03-29 12:58:42 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 21:29:03 -0500
commit27e5fbe617c6755b3ea743c2d61b97515399a9ce (patch)
treebdee8e0029204989b968f2105b9ab0141c4ae317
parentcecb025583a6a4abf34f64c1b52aed7bc154e573 (diff)
gnu: sphinx: Use 'imagemagick/stable' variant.
As the store item does not retain a reference to imagemagick, it should be safe to use the 'imagemagick/stable' variant. * gnu/packages/sphinx.scm (python-sphinx) [arguments] Add #:disallowed-references to make sure no references to imagemagick are retained. [native-inputs]: Use 'imagemagick/stable' instead of 'imagemagick' and explain why that's a safe thing to do. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I04bdc94e012f3fcb30c4ec113a0ae2e9d9373210
-rw-r--r--gnu/packages/sphinx.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 7e5a929241..d2e87ec895 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,7 +75,10 @@
"12cdy3m5c09lpf2bbxzbhm5v5y9fk7jgm94qrzggpq86waj28cms"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ `(;; Make sure it is safe to use 'imagemagick' instead of
+ ;; 'imagemagick/stable' (see the comment for the "imagemagick" input).
+ #:disallowed-references (,imagemagick/stable)
+ #:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -134,7 +138,11 @@
texlive-wrapfig
texlive-xcolor))
(native-inputs
- (list imagemagick ;for "convert"
+ ;; imagemagick is added for "convert". The store item does not retain a
+ ;; reference to imagemagick, so it should be safe to use
+ ;; 'imagemagick/stable' instead of 'imagemagick'. This is enforced by
+ ;; the '#:disallowed-references' above.
+ (list imagemagick/stable
python-cython
python-html5lib
python-pytest))