summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-05-15 21:29:54 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-15 21:29:54 +0200
commit28995b081ee4fea55dedc3ce5b02c1376de5cbcf (patch)
tree93fbec8c2938144f3092880158bc36bbc189cef8
parent4206f3923d107d53d3e0d7cfcd878018c7adb65a (diff)
gnu: psm2: Allow compilation with glibc 2.39.
* gnu/packages/linux.scm (psm2)[source]: Add snippet. Change-Id: Iff29026da7252e4ca35bdde25b24d83bab0d5554
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bed8aae3cc..33964cc243 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2021, 2021-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021, 2021-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
@@ -9093,7 +9093,15 @@ privileges.")
(file-name (git-file-name name version))
(sha256
(base32
- "04nar65ac11qqx41vkfs7iip8kfiah0zms7l4rmsxncpiz2iqfik"))))
+ "04nar65ac11qqx41vkfs7iip8kfiah0zms7l4rmsxncpiz2iqfik"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; That file declares its own 'strlcat' as static. To avoid a
+ ;; conflict with the function now in glibc 2.39, give it a
+ ;; different name.
+ #~(substitute* "ptl_ips/ips_proto_dump.c"
+ (("strlcat")
+ "psm2_custom_strlcat")))))
(build-system gnu-build-system)
(arguments
(list #:make-flags