summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-03-23 09:51:38 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-23 09:51:38 +0100
commit2a0431e064f3508e6baaf6afe66a28b50ffd2651 (patch)
tree752f9a4bbcd7c71551060ddc0e4749813db5a65d
parent5174820753be045ba4fc7cc93da33f4e0b730bc3 (diff)
gnu: Add soapymultisdr.
* gnu/packages/radio.scm (soapymultisdr): New variable.
-rw-r--r--gnu/packages/radio.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 982f218977..15c068bd79 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -453,6 +453,31 @@ controls for certain tuners which may be paired with an audio device.")
"This package provides HackRF devices support to the SoapySDR library.")
(license license:expat))))
+(define-public soapymultisdr
+ (let ((commit "e8bd3298afaec04cb7ce2c8c516cb9cd8bd3bc9d")
+ (revision "1"))
+ (package
+ (name "soapymultisdr")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyMultiSDR")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f7d39s2zpgfi677i2aqp4zkf5c6cv8mpm7w8s7xj45bfhf94acl"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list soapysdr))
+ (home-page "https://github.com/pothosware/SoapyMultiSDR")
+ (synopsis "Multi-device support module for SoapySDR")
+ (description
+ "This is a SoapySDR module to use multiple supported devices under
+a single device wrapper.")
+ (license license:boost1.0))))
+
(define-public soapyrtlsdr
(package
(name "soapyrtlsdr")