summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSuhail Singh <suhailsingh247@gmail.com>2024-03-06 01:17:22 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-17 12:53:20 +0100
commit2ad6e7b43be32bfd186cba54ce5d9e1996a6c36f (patch)
treeaaa3bcfdccb97b2cf032abc06ff3769d6f54e2c9
parent5267c6073c3bdc6ba7874fc776c23c928f1ee263 (diff)
gnu: Add emacs-plan9-theme.
* gnu/packages/emacs-xyz.scm (emacs-plan9-theme): New variable. Change-Id: I6053ce66cfceca5a34d0dfd55691be9346f3a916 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8c3fc5e022..9eaa596233 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34300,6 +34300,29 @@ users with red-green color deficiency.")
(license (list license:gpl3+
license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+(define-public emacs-plan9-theme
+ (let ((commit "c2da2fcb241e9800d931a1ff19ecd9fd84d30382")
+ (revision "0"))
+ (package
+ (name "emacs-plan9-theme")
+ (home-page "https://github.com/john2x/plan9-theme.el")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rjxbk9fljnjmg00vdqcyynzg591cgknyy2d92xsxsyg4d28dvwi"))))
+ (build-system emacs-build-system)
+ (synopsis "Light color theme for Emacs based on Plan 9")
+ (description
+ "@code{plan9} is an Emacs theme with light colors and a classic
+look which is inspired by the colors of Plan 9 from Bell Labs.")
+ (license license:gpl3+))))
+
(define-public emacs-punpun-theme
(let ((commit "7026684cd568cb691af3ced5de14c375fe6f5a1a")
(revision "0"))