summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-20 22:05:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-20 22:22:06 +0100
commit2f4646b6f6028e095c3e03898df0fea4d98c1afc (patch)
treed4aaabb19938c05d0f0ef1eb69f6be0fb248e3b5
parentff7df27d4bdcc31835427713bfae62adc3a592a1 (diff)
gnu: Add jalv.
* gnu/packages/audio.scm (jalv): New variable.
-rw-r--r--gnu/packages/audio.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f6fb236a0a..900d061c6a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -256,6 +256,37 @@ synchronous execution of all clients, and low latency operation.")
;; Most files are under GPLv2+, but some headers are under LGPLv2.1+
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public jalv
+ (package
+ (name "jalv")
+ (version "1.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.drobilla.net/jalv-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1f1hcq74n3ziw8bk97mn5a1vgw028dxikv3fchaxd430pbbhqgl9"))))
+ (build-system waf-build-system)
+ (arguments `(#:tests? #f)) ; no check target
+ (inputs
+ `(("lv2" ,lv2)
+ ("lilv" ,lilv)
+ ("suil" ,suil)
+ ("gtk" ,gtk+-2)
+ ("gtkmm" ,gtkmm-2)
+ ("qt" ,qt-4)
+ ("jack" ,jack-1)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://drobilla.net/software/jalv/")
+ (synopsis "Simple LV2 host for JACK")
+ (description
+ "Jalv is a simple but fully featured LV2 host for JACK. It runs LV2
+plugins and exposes their ports as JACK ports, essentially making any LV2
+plugin function as a JACK application.")
+ (license license:isc)))
+
(define-public ladspa
(package
(name "ladspa")