summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-20 14:05:45 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 15:15:33 +0100
commit3258eae9ee2864cca312ba6f6de9e5b5179218b8 (patch)
treec3bade10a2c398833b8255649103e6b518139525
parent39de9fd90cbace6d062cca7e9df9aef47c143869 (diff)
gnu: qtcolorwidgets: Update to 2.2.0.
* gnu/packages/qt.scm (qtcolorwidgets): Update to 2.2.0.
-rw-r--r--gnu/packages/qt.scm49
1 files changed, 23 insertions, 26 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5ed8ec2c8e..8cbb2c6a07 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3741,35 +3741,32 @@ a binding language:
@end itemize\n")
(license license:lgpl3))) ;version 3 only (+ exception)
-;; There have been no public releases yet.
(define-public qtcolorwidgets
- (let ((commit "a95f72e935fe9e046061a1d1c3930cbfbcb533e0")
- (revision "1"))
- (package
- (name "qtcolorwidgets")
- (version (git-version "0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0dkiwlqh2gwhlp78c1fmchj3shl4p9inspcl96ya5aa8mn6kydy8"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; There are no tests
- (native-inputs
- (list qttools-5))
- (inputs
- (list qtbase-5))
- (home-page "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
- (synopsis "Color management widgets")
- (description "QtColorWidgets provides a Qt color dialog that is more
+ (package
+ (name "qtcolorwidgets")
+ (version "2.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fp7sr5a56bjp2abc6ng331q0bwvk6mf2nxdga81aj6cd9afs22q"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;there are no tests
+ (native-inputs
+ (list qttools-5))
+ (inputs
+ (list qtbase-5))
+ (home-page "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
+ (synopsis "Color management widgets")
+ (description "QtColorWidgets provides a Qt color dialog that is more
user-friendly than the default @code{QColorDialog} and several other
color-related widgets.")
- ;; Includes a license exception for combining with GPL2 code.
- (license license:lgpl3+))))
+ ;; Includes a license exception for combining with GPL2 code.
+ (license license:lgpl3+)))
(define-public qcustomplot
(package