summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 10:13:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:44 +0100
commit34e21fac4fb25a6714e1cb378cdb5a698bd88923 (patch)
tree4e1e532fa6b1cc7ad35633ab2318f80c28753a7f
parentace24a2765ab0c67e5fb1a050d210579b810b05e (diff)
gnu: Add go-github-com-djherbis-times.
* gnu/packages/golang-xyz.scm (go-github-com-djherbis-times): New variable. Change-Id: I5584f32a5ce384cc6ec1c742cf6606b26e6578fe
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7237a0eb00..23712d6fd8 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1000,6 +1000,32 @@ Mark} detection.")
atimes for files.")
(license license:expat)))
+(define-public go-github-com-djherbis-times
+ (package
+ (name "go-github-com-djherbis-times")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/djherbis/times")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a70nqkc592ipbgb3ib4yg8i2yj2hlhalpzzksdlhilm5a3689ic"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/djherbis/times"))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/djherbis/times")
+ (synopsis "File times - atime, mtime, ctime and btime for Golang")
+ (description
+ "Package @code{times} provides a platform-independent way to get atime,
+mtime,ctime and btime for files.")
+ (license license:expat)))
+
(define-public go-github-com-dustin-gojson
(package
(name "go-github-com-dustin-gojson")