summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 21:06:06 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:21:01 +0000
commit35445a7c1a9a788f902594dd7ba0cd3547c7c7e6 (patch)
tree8544b467d3b8b0ba1c1cccb6fe37e4d320c58369
parentb41a40564929f40ed3541c8ce740362b3d13de70 (diff)
gnu: go-github-com-nsqio-go-nsq: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-nsqio-go-nsq): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ie718c9943dd527281b30c78ab4e23adc764289c1
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 27b9043929..e6decd2906 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-compression)
#:use-module (gnu packages golang-crypto))
;;; Commentary:
@@ -377,6 +378,32 @@ library which posts the metrics to the Prometheus client registry and just
updates the registry.")
(license license:asl2.0)))
+(define-public go-github-com-nsqio-go-nsq
+ (package
+ (name "go-github-com-nsqio-go-nsq")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nsqio/go-nsq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h9z3z225sdgg7fl3l7x11xn5ch6lm5flgmcj046cdp453qj2qhf"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:tests? #f ;tests require networking
+ #:import-path "github.com/nsqio/go-nsq"))
+ (propagated-inputs (list go-github-com-golang-snappy))
+ (home-page "https://github.com/nsqio/go-nsq")
+ (synopsis "Consumer/producer library for NSQ")
+ (description
+ "The @code{nsq} Go module provides a high-level @code{Consumer} and
+@code{Producer} types as well as low-level functions to communicate over the
+NSQ protocol @url{https://nsq.io/}.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
(revision "2"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 24c845c7b8..d7c7198cc0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3099,32 +3099,6 @@ sunset times from geographical coordinates and a date.")
queue.")
(license license:expat)))
-(define-public go-github-com-nsqio-go-nsq
- (package
- (name "go-github-com-nsqio-go-nsq")
- (version "1.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nsqio/go-nsq")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1h9z3z225sdgg7fl3l7x11xn5ch6lm5flgmcj046cdp453qj2qhf"))))
- (build-system go-build-system)
- (arguments
- (list #:tests? #f ;tests require networking
- #:import-path "github.com/nsqio/go-nsq"))
- (propagated-inputs (list go-github-com-golang-snappy))
- (home-page "https://github.com/nsqio/go-nsq")
- (synopsis "Consumer/producer library for NSQ")
- (description
- "The @code{nsq} Go module provides a high-level @code{Consumer} and
-@code{Producer} types as well as low-level functions to communicate over the
-NSQ protocol @url{https://nsq.io/}.")
- (license license:expat)))
-
(define-public go-github-com-hebcal-gematriya
(let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
(revision "0"))