summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit35f174ad009d2b896370580463bef163288cebc0 (patch)
treeaf60739cc2d3ac4d4cced91ba402ff00755e876b
parentb4098eecded47ca73187453f8aea1081e7ef642d (diff)
gnu: tmon: Update package style.
* gnu/packages/linux.scm (tmon)[arguments]: Use G-expressions. Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b2bea201d2..3aec03a3ec 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6526,24 +6526,22 @@ supported.")
(source (package-source linux-libre))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "INSTALL_ROOT=" (assoc-ref %outputs "out"))
- "BINDIR=bin")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'enter-subdirectory
- (lambda _
- (chdir "tools/thermal/tmon")
- #t))
- (add-after 'install 'install-man-page
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (man8 (string-append out "/share/man/man8")))
- (install-file "tmon.8" man8)
- #t)))
- (delete 'configure)))) ; no configure script
+ (list
+ #:tests? #f ; no test suite
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "INSTALL_ROOT=" #$output)
+ "BINDIR=bin")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'enter-subdirectory
+ (lambda _
+ (chdir "tools/thermal/tmon")))
+ (add-after 'install 'install-man-page
+ (lambda _
+ (let ((man8 (string-append #$output "/share/man/man8")))
+ (install-file "tmon.8" man8))))
+ (delete 'configure)))) ; no configure script
(inputs
(list ncurses))
(home-page (package-home-page linux-libre))