summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 21:11:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:22:50 +0200
commit383e9a4b0d49e321235fc5098ed8d76adfc37d1a (patch)
tree29b10ac37047aa562fc5ab899b09a4b91afb34ec
parentdc955bb62d587135e78c231a221ce37d0d620329 (diff)
gnu: texlive-platex: Fix build.
* gnu/packages/tex.scm (texlive-platex)[arguments]<#:phases>: Add a phase to deal with duplicate "kinsoku.tex".
-rw-r--r--gnu/packages/tex.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 52468ced8e..aa8493a439 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14036,7 +14036,18 @@ LaTeX packages use of @samp{@@@@}) in nested package files.")
"0a843xnp3iikjxw1klxb3j2bssm6ylhcw32s046xxm2bs527hxi8")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments (list #:create-formats #~(list "platex" "platex-dev")))
+ (arguments
+ (list #:create-formats #~(list "platex" "platex-dev")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ ;; This phase is necessary because the build phase is
+ ;; reluctant to generate "kinsoku.tex" since there is another
+ ;; one among the inputs (texlive-ptex) already.
+ (lambda _
+ (substitute* "source/platex/base/plfmt.ins"
+ (("\\\\keepsilent\n" all)
+ (string-append all "\\askforoverwritefalse\n"))))))))
(propagated-inputs
(list texlive-atbegshi
texlive-atveryend