summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-15 12:58:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-16 07:44:23 +0300
commit3adef1de5389ce197a1a71ee463a83bbdb84ddbc (patch)
treef301a2765079e67361579b885ada284904a36b59
parent651265562bf6fea52c49596f9fb8ec380e5f0022 (diff)
gnu: libinput-minimal: Fix cross-compiling.
* gnu/packages/freedesktop.scm (libinput)[native-inputs]: When cross-compiling add pkg-config-for-build. [inputs]: When cross-compiling add check.
-rw-r--r--gnu/packages/freedesktop.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cf8959d34c..30aa436016 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -554,14 +554,20 @@ freedesktop.org project.")
;; Meson target anyway.
#:build-type "release"))
(native-inputs
- (list check pkg-config python-minimal-wrapper python-pytest))
+ (append (list check pkg-config python-minimal-wrapper python-pytest)
+ (if (%current-target-system)
+ (list pkg-config-for-build)
+ '())))
(inputs
- (list cairo
- glib
- gtk+
- libevdev
- libwacom
- mtdev))
+ (append (list cairo
+ glib
+ gtk+
+ libevdev
+ libwacom
+ mtdev)
+ (if (%current-target-system)
+ (list check)
+ '())))
(propagated-inputs
`(;; libinput.h requires <libudev.h>, so propagate it.
("udev" ,eudev)))