summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-24 21:31:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-24 21:31:58 +0300
commit3d7771146c46248b4b983885de6f1412b08fe2e8 (patch)
tree348dd7abe0f055e21bed4efb6c9047ae7161ac9b
parentf3890d41321560d111f94432005ec9ed7ecc75fe (diff)
gnu: at-spi2-core: Honor the #:tests? flag.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: Adjust the 'check phase to honor the #:tests? flag. Skip the tests when building for powerpc-linux. Change-Id: Ia1fc275ebca5d69b851b566ae7afb47fdad8f066
-rw-r--r--gnu/packages/gtk.scm55
1 files changed, 26 insertions, 29 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index dea7238613..9f6be821ce 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -818,38 +818,35 @@ ever use this library.")
(arguments
(list
#:glib-or-gtk? #t ;to wrap binaries and/or compile schemas
+ #:tests? (not (or (target-ppc32?)
+ (%current-target-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'check)
- ;; The CI test suite fails completely on powerpc-linux.
- ;; The name org.gnome.SessionManager was not provided by any .service
- ;; TODO: Wrap 'check phase with 'tests?'.
- #$@(if (not (or (target-ppc32?)
- (%current-target-system)))
- #~((add-after 'install 'check
- (lambda _
- ;; xfconfd requires a writable HOME
- (setenv "HOME" (getenv "TMPDIR"))
- ;; dbus-run-session may crash if XDG_DATA_DIRS has too
- ;; many entries, maybe related to
- ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
- (setenv "XDG_DATA_DIRS"
- (string-append
- #$output "/share:"
- #$(this-package-native-input
- "gsettings-desktop-schemas")
- "/share"))
- ;; Don't fail on missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (with-directory-excursion (string-append "../at-spi2-core-"
- #$version "")
- (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
- (substitute* "ci/run-tests.sh"
- (("ps auxwww") "") ;avoid a dependency on procps
- (("meson test -C _build")
- "meson test -C ../build")) ;adjust build directory
- (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))
- #~()))))
+ (add-after 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; xfconfd requires a writable HOME
+ (setenv "HOME" (getenv "TMPDIR"))
+ ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+ ;; many entries, maybe related to
+ ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+ (setenv "XDG_DATA_DIRS"
+ (string-append
+ #$output "/share:"
+ #$(this-package-native-input
+ "gsettings-desktop-schemas")
+ "/share"))
+ ;; Don't fail on missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (with-directory-excursion (string-append "../at-spi2-core-"
+ #$version "")
+ (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+ (substitute* "ci/run-tests.sh"
+ (("ps auxwww") "") ;avoid a dependency on procps
+ (("meson test -C _build")
+ "meson test -C ../build")) ;adjust build directory
+ (invoke "dbus-run-session" "--" "ci/run-tests.sh"))))))))
(inputs
(list bash-minimal libxml2))
(propagated-inputs