summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-19 16:38:19 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-20 22:07:23 +0100
commit3de0c6630f3b3a0043fc9431067c399e553bd3f7 (patch)
treea2700dce1d9c87210fe64e62c845b545aaf5d8d0
parent9ee269bae481de99d11225a3ec85efc019bdd569 (diff)
gnu: docbook-dsssl: Refactor install-plan.
Replace custom phase with copy-build-system newly added #:output parameter. Additionally remove extra slashes from license URIs and obsolete inputs. * gnu/packages/docbook.scm (docbook-dsssl)[source]: Remove empty directories from source using a snippet. [arguments]<#:phases>: Relocate 'install-doc logic into … <#:install-plan>: … here. Remove obsolete exclusion rules. [native-inputs]: Remove bzip2 and tar since these are already available by default. [license]: Remove extraneous slash. (docbook-dsssl-doc)[license]: Remove extraneous slash. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/docbook.scm26
1 files changed, 10 insertions, 16 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 1d858d71b7..adb4d3204e 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -513,31 +513,25 @@ V4.1.2 that adds support for MathML in equation markup.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))))
+ "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))
+ (snippet
+ #~(begin
+ ;; Remove empty directories.
+ (rmdir "doc")
+ (rmdir "docsrc")))))
(build-system copy-build-system)
(outputs '("out" "doc"))
(arguments
(list
#:install-plan
- #~`(("./" "sgml/dtd/docbook/"
- #:exclude ("doc" "docsrc")))
- #:phases
- #~(modify-phases %standard-phases
- ;; The doc output contains 1.4 MiB of HTML documentation.
- (add-after 'install 'install-doc
- (lambda* (#:key inputs #:allow-other-keys)
- (mkdir-p (string-append #$output:doc "/share/doc"))
- (symlink (assoc-ref inputs "docbook-dsssl-doc")
- (format #f "~a/share/doc/~a-~a"
- #$output:doc #$name #$version)))))))
+ #~`(("./" "sgml/dtd/docbook/")
+ (#$(this-package-input "docbook-dsssl-doc") "./" #:output "doc"))))
(inputs
(list docbook-dsssl-doc))
- (native-inputs
- (list bzip2 tar))
(home-page "https://docbook.org/")
(synopsis "DSSSL style sheets for DocBook")
(description "This package provides DSSSL style sheets for DocBook.")
- (license (license:non-copyleft "file://README"))))
+ (license (license:non-copyleft "file:/README"))))
;;; Private variable, used as the 'doc' output of the docbook-dsssl package.
(define docbook-dsssl-doc
@@ -560,7 +554,7 @@ V4.1.2 that adds support for MathML in equation markup.")
(home-page "https://docbook.org/")
(synopsis "DocBook DSSSL style sheets documentation")
(description "Documentation for the DocBook DSSSL style sheets.")
- (license (license:non-copyleft "file://doc/LEGALNOTICE.htm"))))
+ (license (license:non-copyleft "file:/doc/LEGALNOTICE.htm"))))
(define-public docbook-sgml-4.2
(package