summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-09-08 20:14:30 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-11 15:50:48 +0200
commit3eeb67c5d9594b3e2ff41ab95183d3ca51a0d893 (patch)
tree3dd325eaa6dbf4690634d4f676ea747a12658ccf
parent22bfc42fab107fa9dfc3fdd4561f6991a67a5a10 (diff)
gnu: Add proj-7.
* gnu/packages/geo.scm (proj-7): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/geo.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 9734ae66fe..b1f251b9c5 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -574,6 +574,27 @@ lets developers use the functionality of Proj in their own software.")
;; src/geodesic.*, src/tests/geodtest.cpp
license:x11))))
+; This is the last version of proj that provides the old proj.4 API.
+(define-public proj-7
+ (package (inherit proj)
+ (version "7.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.osgeo.org/proj/proj-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "050apzdn0isxpsblys1shrl9ccli5vd32kgswlgx1imrbwpg915k"))))
+ (arguments
+ `(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-version
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("MAJOR 7 MINOR 2 PATCH 0") "MAJOR 7 MINOR 2 PATCH 1")))))))))
+
(define-public proj.4
(package
(name "proj.4")