summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-20 00:38:17 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-05-14 00:24:12 +0800
commit40af021e28102d2f4b2e4b2b3c302f487cb1f591 (patch)
treef5c8879caa3241bf16525939f721e315d1e179e3
parent38598c693f67eb75f4152dbdc5d1846e0befd62d (diff)
gnu: foot: Fix cross-compilation.
* gnu/packages/terminals.scm (foot): Fix cross-compilation. [arguments]<#:configure-flags>: When cross-compilation, Remove -Db_lto=true. [native-inputs]: When cross-compilation, Add wayland, pkg-config-for-build. [inputs]: Add wayland-protocols. Change-Id: Ia56d2583254bd9ab463e5b39859eae8eb5092c9b
-rw-r--r--gnu/packages/terminals.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index d18a042785..1c1294f663 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -36,7 +36,7 @@
;;; Copyright © 2022, 2023 jgart <jgart@dismail.de>
;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;; Copyright © 2024 Suhail <suhail@bayesians.ca>
;;; Copyright © 2024 Clément Lassieur <clement@lassieur.org>
@@ -865,16 +865,23 @@ eye-candy, customizable, and reasonably lightweight.")
;; also to address a GCC 10 issue when doing PGO builds.
#:build-type "release"
;; Enable LTO as recommended by INSTALL.md.
- #:configure-flags #~'("-Db_lto=true")))
- (native-inputs (list ncurses ;for 'tic'
- pkg-config scdoc wayland-protocols))
+ ;; when cross-compilation, enable lto will fail.
+ #:configure-flags (if (%current-target-system)
+ #~'()
+ #~'("-Db_lto=true"))))
+ (native-inputs (append
+ (if (%current-target-system)
+ (list wayland pkg-config-for-build)
+ '())
+ (list ncurses ;for 'tic'
+ pkg-config scdoc wayland-protocols)))
(native-search-paths
;; FIXME: This should only be located in 'ncurses'. Nonetheless it is
;; provided for usability reasons. See <https://bugs.gnu.org/22138>.
(list (search-path-specification
(variable "TERMINFO_DIRS")
(files '("share/terminfo")))))
- (inputs (list fcft libxkbcommon wayland))
+ (inputs (list fcft libxkbcommon wayland wayland-protocols))
(synopsis "Wayland-native terminal emulator")
(description
"@command{foot} is a terminal emulator for systems using the Wayland