summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-24 10:15:58 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-13 14:30:35 +0800
commit4284aa7623f87076752625c5313d5be26f1ea571 (patch)
tree8eb58c08835586e6adfa136ca3621b987e91166a
parent83eb96bd2b20fcb499388447ef0f56254522288d (diff)
gnu: wl-clipboard: Update to 2.2.0.
* gnu/packages/xdisorg.scm (wl-clipboard): Update to 2.2.0. [arguments]<#:phases>: Adjust 'patch-file-names. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/xdisorg.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 553fa8d5e2..f9b260b73e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2647,7 +2647,7 @@ Wayland and @code{wlroots} by leveraging @command{grim} and @command{slurp}.")
(define-public wl-clipboard
(package
(name "wl-clipboard")
- (version "2.1.0")
+ (version "2.2.0")
(source
(origin
(method git-fetch)
@@ -2656,7 +2656,7 @@ Wayland and @code{wlroots} by leveraging @command{grim} and @command{slurp}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1g6hcsn4klapvz3bw0k8syixwyyi4cl1c7vbc6f1a2hjpcf4pawn"))))
+ (base32 "0r45k6fk9k26qs88s2sjlgjjamhj2jqghdivlh2xjqknws63d29g"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags
@@ -2669,7 +2669,7 @@ Wayland and @code{wlroots} by leveraging @command{grim} and @command{slurp}.")
(add-after 'unpack 'patch-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (find-files "src" "\\.c$")
- (("\"(cat|rm)\"" _ command)
+ (("\"(cat)\"" _ command)
(string-append "\"" (assoc-ref inputs "coreutils")
"/bin/" command "\""))
(("\"xdg-mime\"")