summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-02-25 14:20:32 -0800
committerAndreas Enge <andreas@enge.fr>2024-03-08 12:55:39 +0100
commit42b228513de8eacbdaab329110c5f0c19ae4b16b (patch)
treedef5a12355c2f73085b8002982676a92b677baf9
parent68b715ac4db5ff09cf9597e1de1062f384243604 (diff)
gnu: Add python-pystray.
* gnu/packages/python-xyz.scm (python-pystray): New variable. Change-Id: If10777c9ec91b549b9937b4825565223786a75cb Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b9c9b9da16..07ca8a9723 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31857,6 +31857,41 @@ handling those variations.")
Qt applications.")
(license license:expat)))
+(define-public python-pystray
+ (package
+ (name "python-pystray")
+ (version "0.19.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moses-palmer/pystray")
+ (commit "1907f8681d6d421517c63d94f425f9cdd74d0034")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vj6c8s7rbc7xc4bi5brx5629ls1ri9prcw9290v85hagilmp609"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ ;; The test suite requires user interaction, there are no automated
+ ;; tests.
+ #:tests? #false
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'sanity-check 'use-dummy-backend
+ (lambda _
+ ;; Without setting this, pystray tries to connect to
+ ;; X11 on import.
+ (setenv "PYSTRAY_BACKEND" "dummy"))))))
+ (native-inputs (list python-sphinx))
+ (propagated-inputs (list python-pillow python-six python-xlib))
+ (home-page "https://github.com/moses-palmer/pystray")
+ (synopsis "Create a system tray icon")
+ (description "This library allows you to create a system tray icon.
+It makes it possible to specify an icon, a title and a callback for when
+the icon is activated. The icon and title can be changed after the icon
+has been created, and the visibility of the icon can be toggled.")
+ (license license:lgpl3+)))
+
(define-public python-bitstring
(package
(name "python-bitstring")