summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2023-03-30 20:32:29 +0800
committerLudovic Courtès <ludo@gnu.org>2023-04-06 18:34:14 +0200
commit452b2ec593405a87661362a0ff2378470d22d3de (patch)
tree30c0a7cd9acfdded74e1cb4e763729414e84c8da
parentb5a35caeeb23b51eacdc8dd6423fe3c4f56207ef (diff)
gnu: tcsh: Fix riscv64 cross-compilation.
* gnu/packages/shells.scm (tcsh): fix riscv64 cross-build. [arguments]<#:phase>: Add 'update-config-scripts' phase for riscv64. [native-inputs]: Add CONFIG for riscv64. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/shells.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index c2b08afbe9..1ffe4ce5d8 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -398,7 +399,10 @@ written by Paul Haahr and Byron Rakitzis.")
(patch-flags '("-p0"))))
(build-system gnu-build-system)
(native-inputs
- (list autoconf perl))
+ (append (if (target-riscv64?)
+ (list config)
+ '())
+ (list autoconf perl)))
(inputs
(list ncurses))
(arguments
@@ -412,6 +416,18 @@ written by Paul Haahr and Byron Rakitzis.")
"CC_FOR_GETHOST=\"gcc\""))
#t)))
'())
+ ,@(if (target-riscv64?)
+ ;; TODO: remove after commit
+ ;; 3c33503f9aec4412dc1a95927a8c5c357c7b851e or 6.24.00
+ `((add-after 'unpack 'update-config-scripts
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub")))))
+ '())
(add-before 'check 'patch-test-scripts
(lambda _
;; Take care of pwd