summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:12:33 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:07:50 -0400
commit4597c0389c6aeae317421ef89850a2de65db0fe9 (patch)
treeb6d1e4eac9261ff9434027d1051ffd67da3e80f1
parent1e009adc2bde0bb0f63d501595b4230ae3132ea3 (diff)
gnu: Add texlive-unicode-alphabets.
* gnu/packages/tex.scm (texlive-unicode-alphabets): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 87004d9f53..155fe5619d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10130,6 +10130,30 @@ providing the LaTeX user with macros which are used to markup textual
information.")
(license license:lppl)))
+(define-public texlive-unicode-alphabets
+ (package
+ (name "texlive-unicode-alphabets")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/unicode-alphabets/"
+ "tex/latex/unicode-alphabets/")
+ (base32
+ "0xvzmx0xa8mmi39a8c89byi6c6y7vbl5k3plp63k5mif19ncyq3s")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/unicode-alphabets")
+ (synopsis "Macros for using characters from Unicode's Private Use Area")
+ (description
+ "While Unicode supports the vast majority of use cases, there are certain
+specialized niches which require characters and glyphs not (yet) represented
+in the standard. Thus the Private Use Area (PUA) at code points E000-F8FF,
+which enables third parties to define arbitrary character sets. This package
+allows configuring a number of macros for using various PUA character sets in
+LaTeX (AGL, CYFI, MUFI, SIL, TITUS, UCSUR, UNZ), to enable transcription and
+display of medieval and other documents.")
+ (license license:cc-by-sa4.0)))
+
(define-public texlive-unitsdef
(package
(name "texlive-unitsdef")