summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-06 16:30:39 +0100
committerLudovic Courtès <ludo@gnu.org>2024-01-06 16:34:13 +0100
commit4770c51afcd549690c5cbaa7d5e131c9b9f0a3ab (patch)
treef9ffd478c1673c6a4c9bbb210810201e69b52a6b
parent404329d950547eb2550029e4c2955d573ce9f9f5 (diff)
Revert "gnu: coreutils: Disable 64-bit time_t on 32-bit systems."
This reverts commit 4eebb73295a8ffdaefcfb7940254ad9c18e4e5d4. The ‘--disable-year2038’ flag appears to be unnecessary (tested on i686-linux). More importantly, it’s potentially harmful as it could prevent rebuilds after year 2038 due to timestamp inconsistencies as they wrap around, and could make the tools unusable altogether. Change-Id: Iad828d38f84bd1824b83731ac3a3897da4b8b6d3
-rw-r--r--gnu/packages/base.scm4
1 files changed, 0 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4a95c67eb1..7d152807b3 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -416,10 +416,6 @@ used to apply commands with arbitrarily long arguments.")
" test-renameatu"
" test-utimensat")))
'())
- ,@(if (not (target-64bit?))
- ;; Not all software is ready for 64bit time_t.
- '(#:configure-flags (list "--disable-year2038"))
- '())
#:phases (modify-phases %standard-phases
(add-before 'build 'patch-shell-references
(lambda _