summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:54:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:39 +0200
commit47a5ed806db3360fac92ac317ce9d5ccbc9fe99f (patch)
treeb29c7b1558dcf339558ff81c4760566744828f58
parent991b989c1b542f2cbb80fba7fa9cd20ec439b53f (diff)
gnu: Add texlive-punknova.
* gnu/packages/tex.scm (texlive-punknova): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8c799761b7..4573766028 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21892,6 +21892,27 @@ Although that bundle also offers support within LaTeX; the present package is
to be preferred.")
(license license:gpl3+)))
+(define-public texlive-punknova
+ (package
+ (name "texlive-punknova")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/punknova/"
+ "fonts/opentype/public/punknova/")
+ (base32
+ "07g0j329bgyzn3f3ac8gf9m6jh6zpwirw5l72mzzm8n32sgajym0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/punknova")
+ (synopsis "OpenType version of Knuth's Punk font")
+ (description
+ "Knuth's original Punk fonts generated different shapes at random.
+This isn't actually possible in an OpenType font; rather, the font contains
+several variants of each glyph, and uses the OpenType randomize function to
+select a variant for each invocation.")
+ (license license:knuth)))
+
(define-public texlive-pythonhighlight
(package
(name "texlive-pythonhighlight")