summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-04-02 21:43:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-04-06 09:16:50 +0300
commit4971d5d0728bcdb79eacf070d6f3b8efb9018924 (patch)
tree788fafc4f90ac13895fda02bfaa6426da055555b
parent7407f7fef6b82adf89d28a4c7dc1e8ed1614f215 (diff)
gnu: Add progress.
* gnu/packages/admin.scm (progress): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/admin.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9636ee939f..406aa0eece 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -100,6 +100,35 @@ usual file attributes can be checked for inconsistencies.")
(home-page "http://aide.sourceforge.net/")
(license license:gpl2+)))
+(define-public progress
+ (package
+ (name "progress")
+ (version "0.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Xfennec/"
+ name "/archive/v" version ".tar.gz"))
+ (sha256
+ (base32 "133iar4vq5vlklydb4cyazjy6slmpbndrws474mg738bd8avc30n"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (arguments
+ `(#:tests? #f ; There is no test suite.
+ #:make-flags (list "CC=gcc" "LDFLAGS+=-lncurses"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; There's no configure phase.
+ (home-page "https://github.com/Xfennec/progress")
+ (synopsis "Program to view the progress of the coreutils commands")
+ (description "A program that looks for coreutils basic commands (cp, mv,
+dd, tar, gzip/gunzip, cat, etc.) currently running on your system and displays
+the percentage of copied data. It can also show estimated time and throughput,
+and provides a \"top-like\" mode (monitoring).")
+ (license license:gpl3+)))
+
(define-public dmd
;; Deprecated. Kept around "just in case."
(let ((base-version "0.2")