summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:59:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:45 +0200
commit4b35360513a24d441e05280a0a70b1c7be7b5523 (patch)
treec842977250d0c45de649828f2359e10cf9f8b07a
parent522e9ca4891984c5cc004cbf6f93a4e535a41981 (diff)
gnu: Add texlive-stepgreek.
* gnu/packages/tex.scm (texlive-stepgreek): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d533435123..093b21f426 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23874,6 +23874,33 @@ Linotype Times, commonly used in publishing. Type 1 support is provided for
legacy TeX engines.")
(license license:silofl1.1)))
+(define-public texlive-stepgreek
+ (package
+ (name "texlive-stepgreek")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/stepgreek/"
+ "fonts/enc/dvips/stepgreek/"
+ "fonts/map/dvips/stepgreek/"
+ "fonts/tfm/public/stepgreek/"
+ "fonts/type1/public/stepgreek/"
+ "fonts/vf/public/stepgreek/"
+ "tex/latex/stepgreek/")
+ (base32
+ "00yh96gdk854yg61hgl7n938lyw11v9kdmwl7klriyq7wjy0zcaw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/stepgreek")
+ (synopsis "Times/Elsevier-style Greek font")
+ (description
+ "This is a beta version of the STEP Greek font. Only a regular face is
+available at present, though there are plans to add italic, bold and bold
+italic in the future. The font only supports LGR in TeX and is meant to serve
+as a Greek complement to a Times-like font such as STEP. The font supports
+polytonic Greek.")
+ (license license:silofl1.1)))
+
(define-public texlive-structmech
(package
(name "texlive-structmech")