summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-20 22:28:54 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-20 22:28:54 +0100
commit4cdda6314cc7624848cdfaac9248ffea0fbc460d (patch)
tree1607b3025b2cdf8c7c8a55db43cf962c7f582234
parent8bd818d6d7ec78b710a1d9427014316bb30421bb (diff)
gnu: libwebp: Ungraft.
* gnu/packages/image.scm (libwebp): Update to 1.3.2. [replacement]: Remove. (libwebp/fixed): Remove. Change-Id: I39c0e5f9df82322dc8dc0ed6341f08c1ac0749b3
-rw-r--r--gnu/packages/image.scm23
1 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 218c714021..221ac1faa6 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2017, 2019, 2021-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017, 2019, 2021-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
@@ -1431,8 +1431,7 @@ language bindings to VIGRA.")
(define-public libwebp
(package
(name "libwebp")
- (version "1.2.4")
- (replacement libwebp/fixed)
+ (version "1.3.2")
(source
(origin
;; No tarballs are provided for >0.6.1.
@@ -1443,7 +1442,7 @@ language bindings to VIGRA.")
(file-name (git-file-name name version))
(sha256
(base32
- "1jndbc99dd19a6d7h4ds51xyak7gfddkbi41nxdm8n23w7ks35r8"))))
+ "1x37795gpc63g1ma9kqw4q3dikwhrjklixqzjjsj6viqksa19z41"))))
(build-system gnu-build-system)
(inputs
(list freeglut
@@ -1471,22 +1470,6 @@ to PNG when lossy compression is acceptable for the red/green/blue color
channels.")
(license license:bsd-3)))
-(define libwebp/fixed
- (package
- (inherit libwebp)
- (name "libwebp")
- (version "1.3.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://chromium.googlesource.com/webm/libwebp")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1x37795gpc63g1ma9kqw4q3dikwhrjklixqzjjsj6viqksa19z41"))))))
-
(define-public libmng
(package
(name "libmng")