summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-16 21:50:51 +0300
committerLudovic Courtès <ludo@gnu.org>2024-06-17 22:51:43 +0200
commit4d6c6540feaf79a148f90a3e8d95e14329525a80 (patch)
tree2334b6da2d64f13a5ce7da1f0129b4b3eabed3a5
parent97b991bf2ba3a5da17d376f76a89eb66a49dd5dd (diff)
gnu: make-libstdc++: Adjust order of phases.
* gnu/packages/gcc.scm (make-libstdc++)[arguments]: Move custom 'fix-rs6000-libdir phase to after the 'unpack phase.
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1cefea8d1d..12b363738a 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -983,7 +983,7 @@ using compilers other than GCC."
(assoc-ref inputs "powerpc64le-patch"))))))
'()))
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
- (add-before 'chdir 'fix-rs6000-libdir
+ (add-after 'unpack 'fix-rs6000-libdir
(lambda _
(when (file-exists? "gcc/config/rs6000")
(substitute* (find-files "gcc/config/rs6000")