summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 23:27:41 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 23:52:52 +0000
commit4da2f179d27420975bfb976e5aa4d11d365a9a2a (patch)
treec68e74913336c9be2d604b41246029a7081b8a04
parentccbf143927a0e39c2a4516d6dfdab40ebfa34ef9 (diff)
gnu: python-devtools: Update to 0.12.2, fix build.
* gnu/packages/python-xyz.scm (python-devtools): Update to 0.12.2. [build-system]: Swap to pyproejct-build-system. [arguments] <#:phases>: Use standard 'check phase. Add 'relax-requirements phase. [propagated-inputs]: Add python-asttokens and python-executing. [native-inputs]: Add python-hatchling. Change-Id: I5562e34443e606d93cd38f8ef8ad58f61e044c86
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 21 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 932e0c48c9..70bfdb60a3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30788,7 +30788,7 @@ and have a maximum lifetime built-in.")
(define-public python-devtools
(package
(name "python-devtools")
- (version "0.6")
+ (version "0.12.2")
(source
(origin
(method git-fetch)
@@ -30797,18 +30797,28 @@ and have a maximum lifetime built-in.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "15zczdcm90wl54c68f1qjb05nkd5bjsc9xjl3lk4frs7k7wkmrvp"))))
- (build-system python-build-system)
+ (base32 "0snmx7f0s44rzzx8advzmgj5av9dlpz1kx05f7ysya8xrhv5nwfl"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; Disable some failing tests.
+ #~(list "-k" (string-append "not test_print_subprocess"
+ " and not test_simple")
+ "--ignore=tests/test_insert_assert.py")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; Pygments 2.12.0 is available.
+ (("2.15.0") "2.12.0")
+ ;; executing 0.8.2 is available.
+ (("1.1.1") "0.8.2")))))))
(native-inputs
- (list python-pytest python-pytest-mock))
+ (list python-hatchling python-pytest python-pytest-mock))
(propagated-inputs
- (list python-pygments))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest")
- #t)))))
+ (list python-asttokens python-executing python-pygments))
(home-page "https://github.com/samuelcolvin/python-devtools")
(synopsis "Debug command and development tools")
(description