summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 09:39:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:22:56 +0200
commit4db922a4d259314a161abcab7e8eb76228ff5960 (patch)
tree1a7851c4b68a6513e157552f4f1f07bf347da3ff
parent91c34911a1a7e2f4ad667af241e1b510a7daea34 (diff)
gnu: Add texlive-diagbox.
* gnu/packages/tex.scm (texlive-diagbox): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0b15a91f21..cf368b3dae 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4495,6 +4495,29 @@ custom derivatives and differential operators. The options follow
a consistent naming scheme making them easy to use and understand.")
(license license:lppl1.3+)))
+(define-public texlive-diagbox
+ (package
+ (name "texlive-diagbox")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/diagbox/" "source/latex/diagbox/"
+ "tex/latex/diagbox/")
+ (base32
+ "0zr7ih8jr56j727gf3l1q87rlrqn3zfz8cm7hs2q5l1f3y1gmcgh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/diagbox")
+ (synopsis "Table heads with diagonal lines")
+ (description
+ "The package's principal command, @code{\\diagbox}, takes two
+arguments (texts for the slash-separated parts of the box), and an optional
+argument with which the direction the slash will go, the box dimensions, etc.,
+may be controlled. The package also provides @code{\\slashbox} and
+@code{\\backslashbox} commands for compatibility with the now removed slashbox
+package, which it supersedes.")
+ (license license:lppl1.3+)))
+
(define-public texlive-diffcoeff
(package
(name "texlive-diffcoeff")