summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:24:02 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:24:02 +0100
commit4e4aebde6a825310dd2018ed8717944ee3f2bf69 (patch)
tree1032b233573c6d5454067533e868070afd2949b1
parent9b6ff81352b1f3c3c0f4f7ca0c64c1ece3562472 (diff)
gnu: go-github-com-kballard-go-shellquote: Sort alphabetically.
* gnu/packages/golang-xyz.scm (go-github-com-kballard-go-shellquote): Sort alphabetically. Change-Id: Ie73d9136b6a45467e718f1d85fc97d965b1257b2
-rw-r--r--gnu/packages/golang-xyz.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9b0f67de6f..5a2381eed2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1462,6 +1462,33 @@ called concurrently with themselves and each other.")
customized globally.")
(license license:expat)))
+(define-public go-github-com-kballard-go-shellquote
+ ;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
+ (let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")
+ (revision "1"))
+ (package
+ (name "go-github-com-kballard-go-shellquote")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kballard/go-shellquote")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rspvmnsikdq95jmx3dykxd4k1rmgl98ryjrysvl0cf18hl1vq80"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kballard/go-shellquote"))
+ (synopsis "Shell-style string joins and splits")
+ (description
+ "Shellquote provides utilities for joining/splitting strings using sh's
+word-splitting rules.")
+ (home-page "https://github.com/kballard/go-shellquote")
+ (license license:expat))))
+
(define-public go-github-com-lib-pq
(package
(name "go-github-com-lib-pq")
@@ -1554,33 +1581,6 @@ Printf/Sprintf etc.")
(native-inputs
(list go-github-com-stretchr-testify))))
-(define-public go-github-com-kballard-go-shellquote
- ;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
- (let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")
- (revision "1"))
- (package
- (name "go-github-com-kballard-go-shellquote")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kballard/go-shellquote")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1rspvmnsikdq95jmx3dykxd4k1rmgl98ryjrysvl0cf18hl1vq80"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/kballard/go-shellquote"))
- (synopsis "Shell-style string joins and splits")
- (description
- "Shellquote provides utilities for joining/splitting strings using sh's
-word-splitting rules.")
- (home-page "https://github.com/kballard/go-shellquote")
- (license license:expat))))
-
(define-public go-github-com-marcinbor85-gohex
;; No release, see <https://github.com/marcinbor85/gohex/issues/5>.
(let ((commit "baab2527a9a2a4abb3dc06baabedfa5e0268b8d8")